Recherche rapide
Trouvez la bonne solution pour votre véhicule.

Questions & Answers

2011 S4 (manual trans) doesn’t sense key while still in key port after a normal start.

0 votes
Hey,

Installed EVO-ALL with separate remote starter using t harness. All commands/triggers work as expected from the remotes, including remote start (and key takeover when remote started).
If started normally using the key port, the car starts, but key is not sensed in the port so once a door is opened/closed, reservation mode will set with the key still in the port, then shutdown the engine.

I'm using the CM7000 - should I splice the Key Sense INPUT (of the CM7000) to the "Key In" (EVO-pin A20)? I thought this would have been communicated over data, but maybe not.

Any other ideas, or suggestions?

Car: 2011 S4 Manual Trans. Keyport
Service #: 001A06901001

Thanks.
posté Mar 5 dans la catégorie Audi par Daryl Keyser (130 points)
modifié Mar 5 par Daryl Keyser

3 Réponses

0 votes
It is the drivers responsibility to ensure the key is removed from the vehicle when exiting.
répondu Mar 5 par Derek (191,280 points)
I get that. Not the intention of the question...

Why does the reservation mode initiallize while the key is still in the port? If I park and let someone out of the car (door open/close), reservation mode will initialize and shut down the car even though the key has not left the port.

I've tried several CM7000 reservation options, but the remote start module must not be receiving a "Key In" signal - shouldn't that be transmitted via data?
Reservation mode is not even controlled by the evo-all. Turn off the automatic enabling of reservation mode in your starter. Your questions about how the compustart works though would be better answered by compustar.

Yes, I'm aware reservation mode would be controlled by the separate remote start, however I thought the EVO would communicate to the remote start that the Key is in the keyport over data - which would then not allow the reservation mode to initialize. 

I should be able to use A20 (output from EVO) to communicate with the remote start that the key is still in the keyport?

A20 only outputs upon remote start (once the GWR signal is received).

But, at the same time, A20 is connected to the vehicles (-) Key In signal. So, you could use it. Compu may require a (+)keysense input though.
Thank you for providing this info Robb - as well as the polarity!

 

Compu does use a (-) input, so all good there - but nothing a relay couldn't have solved quickly enough.
Dam, that didn't work either...
 

I did finally notice that the firmware loaded on the EVO was actually 60.05 (guide spec's 60.02 - my bad). Loaded 60.02 version up, which prevents the unwanted shutdown, but also doesn't allow any Key-Release. I confirmed it is a 2011 (10 character of VIN is "B") so 2009-2010 connector is NOT connected.

What changed between 60.02 and 60.05 regarding the Key-Release?
0 votes

A20 on the evo is an output to the vehicle Key In (key sense) at the key port in order to remote start correctly. 

 

other than that, not sure to understand your question but i think to know. 

 

When setting reservation mode when the car is started with the key in the key port, you need to take the key out without pressing on the key. Or else the car will shut off since that's how you normally shut down the car (by pressing on the key in the key port). 

 

If you cannot simply slide out the key without actually pushing in the key first, there is a problem with the Key-Release control. If the vehicle is actually a 2011, make sure the connector labeled 2009-2010 ONLY is not connected. To make sure, check the 10th letter of the VIN counting from the left. If it's an A, car is a 2010. 

répondu Mar 5 par Robb (241,260 points)
démasquées Mar 5 par Robb

Thanks for clarifying A20 is an output from the Evo to the car. 

I think I could still use this as an INput signal to the CM7000 so the remote starter knows the key is still in the keyport and reservation won't initialize when a door is opened/closed. I thought a Key is in keyport signal would have been communicated to the CM7000 via data. 

 

I am able to release the key from the port, so "key release" is working. 

 

 

I dont know the ins and outs of a Compu remote starter, especially on manual transmissions which extra layers of protection. i would highly suggest contacting them.
0 votes
1.Setting reservation mode requires that the vehicle is running

2.For the vehicle to be running, the keyfob needs to be in the keyport.

3.So, if you want the remote starter not to go into ready mode with the key in the keyport, how do you expect it to work?

 

If you are dropping someone off, you can either,

1. not engage the parking brake and just simply hold the brake pedal.

2. set the remote starter to only engage ready mode through a start command via an RF kit.

 

If you are not a shop/professional installer, I highly recommend bringing the vehicle to one to have them look over your installation.

If you are a shop/professional installer, we shouldn't be having this conversation.
répondu Mar 5 par Rico (54,260 points)

1/2. Ha ha yes, I'm aware of that.

3. I want the remote starter to be ready but not complete reservation shutdown, until AFTER the key has been removed and doors closed - not WHILE the key is still in the keyport.

 

Yes, I've not engaged the parking brake as a work-around. Not great if there's any incline!

1. If I have to get out for any reason (I'm using the park brake so it doesn't roll anywhere), once the door closes, reservation completes and shuts down the engine - all while key is in the port. 

2. Tried that, but still no go. The starter thinks resveration mode is already set and will command remote start. (Definitely not a Fortin issue).

 

All I really needed to know was whether a key sense signal was communicated between bypass and remote start module over data. 

No...
...