Quick Vehicle Finder
Find the right solution for your vehicle

Questions & Answers

2004 Corvette with EVO ONE, programs correctly but will not remote start

0 votes
Hello everyone. Working with a 2004 Chrevrolet Corvette. Have an EVO-ONE with the recommended 70.18 firmware installed. The bypass programs correctly... However, when commanded to remote start with the RM942 fob, it attempts to start, but it wont crank. Parking lights come on, ignition and accessories turn on, everything's great.. just no crank. As a test, I left he key in the ingition and arttempt to remote start.. It starts fine!   Is the EVO not bypassig correctly before it attempts to turn on the car ?  If it helps... 002B07336612
asked Dec 16, 2019 in Chevrolet by Ed Andre (380 points)
edited Dec 16, 2019 by Ed Andre

1 Answer

0 votes

One thing that is odd in your thread "I left he key in the ingition and arttempt to remote start.. It starts fine! "

This doesnt make sense to me since a passlock system does not use a chip in the key. The pass lock is based on the ignition barrel. "The PassLock system works when the lock cylinder moves a magnet past a Hall effect sensor. The sensor then sends a signal to the control, which GM has moved several times over the model years. The control then sends the code to the PCM. If the code is correct, the PCM will allow the car to start and run."

 

The key bypass is done on the J1850 connection. I would first start by re checking this connection. if any type of wuick connect was used, remove it and make a proper connection. 

 

You can also try flashing 70.21 into the module, re program it and re test it. 

answered Dec 16, 2019 by Derek (178,310 points)
I hear ya. But it seems to be a simple vats based system. I actually stuck a 7.4kohm resistor in the harness to test and sure enough the car starts great without the key. (measured the pellet in the key of course). I think my connection to the odb2 connector is good. Otherwise I would not be able to lock and unlock the doors with the fob.
Being VATs, can i suggest simply going good old resistor with a relay method?
I could... its just that I wasn't expecting it not to work. What output on the EVO-ONE could I use to energize the relay while cranking ?
Dark.blue wire on the 20 pin connector.

VATs was never covered through data. Even way back when with older modules like the INT-SL. They required the Passlock-SL2 or simply relay a resistor. 

 

https://www.the12volt.com/relays/relaydiagram41.html

Yeah it's a simple system...

 

Well, I recommend updating the installation guide for the 2000-2004 Chevrolet Corvette to specify the immobilizer function doesn't do anything :) That would be > https://fortin.ca/download/60581/evo-one_ig_reg_bi_gm_corvette_j1850_2000-2004_b_60581.pdf

 

I wonder why they would go through the trouble of writing that up, if it doesn't even work though ? What's the purpose ?
Well I went ahead and soldered in the right resistor to bypass it permanently. But other than that, it works great.
...