Quick Vehicle Finder
Find the right solution for your vehicle

Questions & Answers

FAQ: RED LED STUCK ON

+5 votes

When a module is stuck on the RED LED. 

  1. flash version 0.99
  2. disconnect unit from the flasher and power cycle it in the car (connect/disconnect power connector)
  3. connect module back to the flash link and flash whatever firmware you need
  4. Turn settings protection OFF if it's on and SAVE the options.
  5. Reset the unit following the reset procedure. (this cannot be done while module is connected to the flash link) : https://fortin.ca/en/qa/50193/faq-how-do-i-reset-my-evo-all?show=50193#q50193
  6. Connect module back to the flash link and enable required options.
  7. Reprogram module to the vehicle following instructions in the installation guide.

 

Reasons this happened.

  • Unit was connected WHILE doing the install.
  • Unit was disconnected during CAN programming before the blue led started to flash.
  • Power was disconnected while all other connectors were still connected. 
  • during an update or save of options, the flash link lost connection to the module or the internet
  • RF protocols not setup correctly, or RF device not paired to unit correctly.
  • Datalink protocols not setup correctly.
  • Bad ground.
  • Loss of power during writing of data to the module.
closed with the note: Closed, for info only.
asked Nov 14, 2019 in FAQ by Robert T (279,340 points)
closed Feb 19, 2021 by Robert T
...

Wirecolor.com

the ultimate online tool

Visit wirecolor.com for wiring information and photographs providing detailed installation processes.

Email Sign Up

Get products & corporate
updates with our newsletter.