Quick Vehicle Finder
Find the right solution for your vehicle

Questions & Answers

2015 Jeep Cherokee Red light flashes 3 times and doesn't start

0 votes

I am having trouble with the installation of an evo-chrt6 standalone t-harness on a 2015 Jeep Cherokee standard key (no push to start) All wiring is hooked up and confirmed correct. The unit is flashed for a standalone install with no alarm. I have used the recommended settings. I am getting a 3 flash code on the red light on the evo (parking lights flash accordingly with this code after the lock button is pressed three times but it is not cranking or starting. Looking at the instructions, 3 flashes indicates something to do with a tach although I do not believe this model vehicle has a tach wire to be hooked up. What should I try to get this working?

asked Dec 17, 2018 in Jeep by Jordan Owens (130 points)

1 Answer

0 votes
is this just in add on mode? No aftermarket RF kit? If so try changing it from 3x lock start to LOCK-UNLOCK-LOCK. and see if thats the ticket. Another thing to try would be to take the YELLOW/BLACK wire(A13) to ground for a second and see if the model starts it that way. If it does, than it's operator error, if not than I would say it's programmed incorrectly or not flashed to the current firmware version.
answered Dec 20, 2018 by Joshua Halsey (630 points)
...

Wirecolor.com

the ultimate online tool

Visit wirecolor.com for wiring information and photographs providing detailed installation processes.

Email Sign Up

Get products & corporate
updates with our newsletter.