Quick Vehicle Finder
Find the right solution for your vehicle

Questions & Answers

EVO GMT3 stuck on step 4

0 votes
I can complete steps 1-3, but when I get to step 4, the part where you turn the key to the on/run position, the red light is not flashiing.  The red and yellow light just stay solid the whole time.

The only weird thing that isn't mentioned in the directions is that my ignition has to be turned to the on/run position for the module to turn on when I start step 1. I tried turning the key all the way to the crank position in step 4, but the lights stayed solid and the red light did not blink.  So maybe the problem is that I can't start the process correctly.  I am not sure what to do.

Fortin EVO-GMT3

2015 Chevy Silverado 1500

Flashed with OMEVOFLASHLINK

 

Edit: I just found the troubleshooting part of this site and I may have a blown fuse. I have no idea what the fuse is or where it is located.  Everything electrical seems to work fine and the truck starts up and runs with no problems.

 

Edit 2: I talked to one of the techs from the help line and he said that I probably have a bad wire harness.  I checked the harnass, removed all of the unneeded wires and checked the positive and negative wires. They look good, but I replaced both of them anyway. Still no luck.  Blah.

 

Edit 3: (Yeah, I know....) It seems to me that the main problem that I have is that the module, while hooked up doesn't have a constant, always on power source.  Can a hot wire be spliced into the red, hot wire to provide a constant power source, or will that cause problems with the ignition?
asked Dec 14, 2018 in GMC by Daniel Urquhart (160 points)
edited Dec 15, 2018 by Daniel Urquhart

Please log in or register to answer this question.

...

Wirecolor.com

the ultimate online tool

Visit wirecolor.com for wiring information and photographs providing detailed installation processes.

Email Sign Up

Get products & corporate
updates with our newsletter.