Quick Vehicle Finder
Find the right solution for your vehicle

Questions & Answers

Help me please in evo one with kia rio 2013

0 votes
Something happened to my evo one...before everything work well..my children play with the key and the brake pedal after that the rf kit not working... When I try to program it no responce

i program again the evo one with my car till the blue led flashes rapidly

but i cant program the excalibur rf51-edp like before

also i noticed that when i program the evo one the park lights not flashing like before during programming with the rf kit
asked Mar 5, 2018 in Kia by SHERIF REZKALLAH (370 points)
edited Mar 5, 2018 by SHERIF REZKALLAH

1 Answer

0 votes
Some remote have a keypad lock feature that will disable all buttons on the remote. Check with Excalibur if they have such feature. Kids somehow always find the button combination to enable this function.

Kids playing with the ignition and brake will not disable EVOONE... Sounds like something with the remote or the antenna.
answered Mar 5, 2018 by Mathieu Bertrand Collin (62,040 points)
this step not working

l did but no response from the remote or the antenna
the strange that when i press the button  on the antenna 2 times it gives me 5 rapid peep sound
i think something happened to the programming but i dont know where
You should contact Excalibur, the EVOONE is going into programming mode but your antenna is not sending anything to it.
Hello...no problem from the rf kit....I did master reset to evo one... After that all working again but some changes in the settings... I did order to buy flashlink 1.... Thank you so much... I wait the updater to make my favorite settings and contact you to help me... Thanks again for your help and support
...

Wirecolor.com

the ultimate online tool

Visit wirecolor.com for wiring information and photographs providing detailed installation processes.

Email Sign Up

Get products & corporate
updates with our newsletter.