Quick Vehicle Finder
Find the right solution for your vehicle

Questions & Answers

2003 Dodge Ram 2500 Diesel Bypass won't program, Intsl+ or EVO-all

0 votes
Installing Autostart on 2003 Dodge Ram Diesel 2500. I have used the intsl+ on these several time without a problem. During installation I couldn't get it to program the bypass. I flashed the bypass with almost every different software version that was availiable. I redid conections and tried 4 different intsl's . Each one did the same thing, I changed the bypass to the EVO-all. I had to flash it again with a different version. It worked but later that day the customer called and told be it stopped working. Any Idea's? I checked the wires coming from the vehicle to see if for some reason they were colors changed and maybe I hooked them up wrong, but everything seems to check out. I have never had a problem with these programming before.
asked Dec 3, 2013 in Dodge by Scott St.Denis (430 points)

1 Answer

0 votes

Hi Scott,
 

I'm just going to mention what has been seen in the past.

First, since you have an EVO-ALL that did program but stopped working, you may want to try without having door locks of the remote starter connected to the purple and purple/white of the EVO. We`ve been seeing cases lately that the Autostart sends a disarm pulse way to close to sending (-)Ground-when-Running. This doesn't allow the EVO to work properly.



With the Int-SL+:
We have 2 Chrysler specific firmwares for odd cases like you mentionned.

  • 0.55 - For vehicles who do not want to program
  • 0.54 - Fix Chrysler, when unit program and do not start
  • When programming the unit, dont bother doing the step where it mentions hitting unlock on the remote starter remote. All this does is lock the unit in datalink mode.


With the EVO:

  • 4.06 or the latest Beta firmware only. We removed all J1850 databus on firmwares above 4.06, but it has been recently reintroduced in the Chrsyler/Dodge/Jeep firmware. 74.[xx]
  • You may want to try with J1850 wire at the OBD-II and not at the transponder.
  • Connect the Yellow wire of the EVO directly to the cars ignition, not at the transponder.


The EVO might also like a master reset after changing the firmwares. Here is the procedure.

  1. Hold down programming button while plugging in datalink connector.
  2. Let go of button when LED is RED.
  3. Push and hold button again until all three LEDs start to alternate.
  4. Disconnect unit, she is now reset.
answered Dec 3, 2013 by Robb (201,900 points)
Still not working
...

Wirecolor.com

the ultimate online tool

Visit wirecolor.com for wiring information and photographs providing detailed installation processes.

Email Sign Up

Get products & corporate
updates with our newsletter.