Quick Vehicle Finder
Find the right solution for your vehicle

Questions & Answers

Cannot get Revo 4.1 kit to program to Evo One.

0 votes
When trying to program key fobs using guide 88751. I press and hold the valet button, I get a yellow light on top and rapid red led flashing on side below loop. I press the valet 5 times press, press the brake once but no park light flash, and nothing when pressing lock on the fob for 3 to 5 seconds.
asked Oct 27, 2021 in Chevrolet by Carlos Paige (750 points)

1 Answer

+1 vote
If nothing happens after the brake press, the module is not detecting the brake.

To replicate brake press without actually pressing on the brake, take the black wire from the 20-pin connector and give it 12V for 1 second instead of pressing the brake
answered Oct 27, 2021 by Robert T (284,390 points)
Tried the black wire from 20 pin to 12v for one second, still nothing. I forgot to mention FW 70.18  and 1.25 are installed. I went back and reset the bypass, A1-A11 are now On. Now when I turn the ignition to on and press the valet button, only solid yellow on top no longer getting the rapid red flashing below the loop. Tried using oem fobs with C1 and 38.2 enabled but only get the doors locking 3x. Any idea of what I'm missing.
Turns out I'm getting 3.4v at the brake wire when the vehicle is switched to on, making the module think the brakes were pressed. Got the fobs to program by disconnecting the brake wire. And using your suggestion in the program procedure.
...