Quick Vehicle Finder
Find the right solution for your vehicle

Questions & Answers

2012 lancer se

0 votes
Hi there

about a year ago I purchased evo-one for my mitusbishi lancer se 2012 it was working fine until i stop using it for 2 months I updated the firmware to the latest. when I tried to reset it and reprogram it the lights flash but the engine doesn't want to turn over. I get a warning that my driver side door is open which its not and the when I hit the button on the key the first time the red lignt next to the reset switch flash raipdly when i hit it the second time it slows down and the third it turns off

now on the module itself the three leds first the blue then the red goes soild then the yellow and back to blue flashing

I want to know how can I downgrade the firmware for the remote starter and bypass. because I think that what making it not work right

 

Thank you
closed with the note: aftermarket LED brake lights causing feedback on brake circuit resulting in no start.
asked Jul 20 in Mitsubishi by Petey JR (180 points)
closed Jul 26 by Derek

1 Answer

+1 vote
 
Best answer
When logged into flash link click on the gear in the upper right hand coner, then click "go to pro mode".

 

Once the screen re loads, directly under the listed version it will say "view other firmwares" simply click that and you can roll back the version.

 

Please note that when changing firmware you must re program the entire unit this includes dcryptor if applicable.
answered Jul 20 by Derek (227,910 points)
selected Jul 30 by Robb
Update:

Using version 74.22.

Turns out the client had installed LED brake lights that were feeding back causing the evo to see a brake signal.

 

Re installed OEM bulbs and vehicle remote started successfully.

 

Thank you for your patience petey JR.

 

Best Regards.
Goodevening Derek

I want to say thanks first and formost for helping me out here i wish i could give you a hug for helping out but instead I hugged my laptop haha. I didn't expect this to happen due to leds  feedback loop. I found out something interesting I took out one of the led bulbs and replace it with the oem bulb and it started up. Alittle supprised but ok. I don't have no loader on the rear tail lights. I havn't installed a load resistor onto it to see if it can bypass if it can well there something new to add to the list of things or find a way to bypass the feedback loop.

 

Thanks

Petey
Hey Derek I have. Request here would it be possible to get longer 6pin connector, im trying to put the device under my seat or have a t harness made for the lancer Let me know Thank you
The main 6 pin connectors come in a generic length. Fortin does not make a long version and a short version. Alternatively you could always lengthen the wires to your desired length.
Would that effect the outcome of the device making it not function correctly Thank you
...