Quick Vehicle Finder
Find the right solution for your vehicle

Questions & Answers

Cannot change button mapping to trunk or Aux Feature - OMEGA OL-RF-42-SST - EVO-ONE

0 votes
Suscefully installed Evo-one on my 2018 MAzda cx-9.

Added an OMEGA OL-RF-42-SST RF kit and it programmed no problem using OM 0.44 FOR OMEGALINK.

Everything works fine, OEM remote still 3x starts car if needed and Omega remote starts, locks and unlock doors no problem.

BUT I CANT get any button mapping done.

Can't get RF remote to open Trunk or Map any of the buttons to operate AUX 1 function??

 

Is this something that's not possible ?

Doing Ignition "on", hold down valet switch, get fast blinking LED, Press & Release Valet for # for mode wanted, press and release brake, Then press "desired button on RF remote, but nothing happens,

 

Using: MODE 1 - LOCK MODE 2 - UNLOCK MODE 3 - TRUNK MODE 4 - START MODE 5 - AUX.1 MODE 6 - AUX.2
asked Jun 22 in Mazda by Jaime Penaranda (190 points)

2 Answers

0 votes
We do not support trunk open through data on a 2018 cx-9. That is why it doesnt work from the remote. https://fortin.ca/download/68271/evo-one_ig_thr_bi_maz3-cx9-cx3_pts_2014-2017_1key_a_68271.pdf

 

You do have 1 aux output, which is the yellow/black wire on the evo-one. There is no Aux in data.

 

You could hook up yellow/black to the tail gate wire at the switch on the dash to get tailgate open if you wanted.
answered Jun 23 by Derek (227,350 points)
Is there something else that I have to deactivated in order for this to work?

I connected the trunk switch wires using a relay ciircuit. I have (+) 12 V powering the relay at less than 500mA to avoid any damaged.

I tested this circuit by grounding the connection ( where the Yellow/black wire would go) and it open and closes the trunk no problem).

Also doubled checked the current going thru the relay ~400mA.

But when I press the AUX function on the Rf remote if won't open and close the trunk?
Check to see if you get any output on yellow/black when hitting trunk button or aux1 button. It will be a negative signal.
0 votes
Derek has you covered, but wanted too mention.

Mode 1 - lock

mode 2 - unlock

etc.... is NOT for mapping the buttons on the remote. It's to allow changing the REMOTE STARTER options in the car VS at the PC. There are 39 different remote starter options that have 6 different MODES (ie Lock - mode 1, unlock - mode 2 etc....). The remote starter options can be changed manually or at the flash link.

Playing around with that, sounds like you might have also changed the first 6 remote starter options to random settings.
answered Jun 23 by Robb (262,210 points)

The only Trunk/AUX output on the unit is the yellow/Black wire. 

My only other suggestion is to turn off option 39, if it's enabled at the moment. It plays around a bit with how that output operates. 

Thanks Rob Option 39 is disabled. I made sure to check it when I changed option 25. I'll test the output on the Aux-wire 1st. If that's working, then I'll check my relay connection again. If the Aux wire(yellow/black) doesn't ground when I press and hold the trunk button, then that'll leave me at a dead end at that point We'll see. This will be a busy weekend so maybe Sunday or Monday I'll get a chance to test it
Hi Rob thanks for all the assistance. Tested the yellow/black wire and it grounded like it was supposed to when holding down the trunk button. Turns out one of relay wires broke off the harness. Replaced the relay with a (Relay Module With Optocoupler Isolation Support High or Low Level Trigger) All is working perfectly now. Thanks
Rob is away from his desk at this time but I will pass the message along.

 

Glad you got it sorted.

 

Best Regards.
THANKS DEREK!.. You guys offer great support
...