Quick Vehicle Finder
Find the right solution for your vehicle

Questions & Answers

2007 Elantra won't program can

0 votes
I am installing a Evo one remote start in a 2007 Elantra with T harness no immobilizer.  After setting the module to Blue and connecting the A1 and C1 harness and turning the ignition on to start programming step 4 - 5 the blue LED does not flash. I have followed the trouble shooting steps and have verified, Yellow wire A1 is correctly connected to pink ignition wire+, the can bus wires are correctly connected to gry/black can low to yellow (pin14) on the DLC and gry can high to white (pin6) on the DLC. I have verified can voltage high at 2.6 and can voltage low at 2.4, I have tried to balance the signals closer to 2.5 but I am unable to make a significant or stable change from those readings.
asked Dec 10, 2020 in Hyundai by daniel baldwin (150 points)

1 Answer

+1 vote
As long as the vehicle is automatic transmission, If it wont program can simply set 20.2 in the evo-one for tachless and hook up the brake wire. Then just skip can programming all together.
answered Dec 10, 2020 by Derek (227,350 points)

That is the way I have it setup now. 20.2 tachless and -1 for crank time. It seems to be working good without starter grind or excess spin. I'm just curious if there was excended trouble shooting available such as known ohm reading at the C connector on the module or anything of the sort to verify if its a dead pin on the module or if the CAN signal on the vehicles can is to "noisy" for the module to read it. Either way running tachless works for me, it's just not my prefered method. Thanks for your reply! I couldn't have imagened getting an answer so fast.

 

...