Quick Vehicle Finder
Find the right solution for your vehicle

Questions & Answers

1 of 2 RFK 912 Remote Will Not Pair to Evo-One

0 votes
The vehicle is a 2017 Mazda CX-9 with EVO One previously installed. I added the RFK912 two way remotes and antenna, but only one remote programs successfully to the antenna.  The second remote lights go solid blue-flashing blue five times-solid red briefly with a beep while holding the button.  I have confirmed that the antenna LED is flashing blue in learn mode.

After programming attempts, the vehicle does not respond to the second remote but the first one works fine.   The factory remotes start the vehicle with Lock-Lock-Lock, too.

I have already ensured that the EVO-One and antenna are flashed to the latest firmware.
asked Dec 5, 2020 in Mazda by PJ Harris (130 points)

1 Answer

0 votes
Sounds like you didnt hold the button long enough, after it lights up red keep holding it until it comes on solid blue, then let go.
answered Dec 7, 2020 by Derek (227,350 points)
It never turns blue again and the antenna LED stops flashing. The first remote never lit up red either.
Could you please take a video using your smart phone of the remote in question not lighting up  properly when in pairing mode.

 

Send it to support@ifar.ca and put attention derek.
I have the same problem on a 2020 RAV4 with T-harness. Is there a solution?

Thank you!
im having the same issue on my 2009 corolla with rf kit 1W FTX84

i can only one remote to program and the other wont pair no matter how many times i tried.
...